i like the idea of having the name of the port prepended to the signals (and other records) however the extra line length added with the compact nature of the PortInterface declararion.
it would i think be much better to have *all* RecordObjects do this.
the only thing is it involves digging into the Signal (or Record) to obtain a name.
this might involve a bit of code duplication from nmigen.
__setattr__is overridden in RecordObject already, so there is access to the Signal (or Record) being added, and at that time it becomes possible to mess with the name.
Fixed in nmutil f61e3beee
ha, hilarious i was just thinking name name thing, great to see you also thought about Record as well.
PortInterface is a looot tidier, neh?