Bug 454 - Create "subset instruction decoders" that are *inside* mul0, *inside* alu0 and so on
Summary: Create "subset instruction decoders" that are *inside* mul0, *inside* alu0 an...
Status: RESOLVED DUPLICATE of bug 359
Alias: None
Product: Libre-SOC's first SoC
Classification: Unclassified
Component: Source Code (show other bugs)
Version: unspecified
Hardware: PC Linux
: Normal normal
Assignee: Luke Kenneth Casson Leighton
URL:
Depends on:
Blocks: 383
  Show dependency treegraph
 
Reported: 2020-08-08 20:56 BST by Cole Poirier
Modified: 2020-08-08 21:39 BST (History)
1 user (show)

See Also:
NLnet milestone: NLNet.2019.Coriolis2
total budget (EUR) for completion of task and all subtasks: 0
budget (EUR) for this task, excluding subtasks' budget: 0
parent task for budget allocation:
child tasks for budget allocation:
The table of payments (in EUR) for this task; TOML format:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cole Poirier 2020-08-08 20:56:41 BST
from https://bugs.libre-soc.org/show_bug.cgi?id=199#c58

```the number of oper_* pins is far too large.  this is the "expansion" of the instruction for convenience.  an example is the 64 bit immediate.

basically i am going to have to do "subset instruction decoders" that are *inside* mul0, *inside* alu0 and so on.

i have to find time to do that.

until then i think we stop with the floorplan version and go with "flat".
```

Luke, can you edit this tomorrow - since I know you're resting today recovering from yesterdays driving ordeals - to include more details about what needs to be done?

Also, I think I have categorized it under the correct milestone and that it blocks bug #383 'Complete first functional power9 core' but I also think I may be mistaken so please correct me :)
Comment 1 Luke Kenneth Casson Leighton 2020-08-08 21:26:23 BST
appreciate the help raising bugreports, in this case i planned and noted it 3 or so weeks ago.  however the subject libe is particularly obtuse.

*** This bug has been marked as a duplicate of bug 359 ***
Comment 2 Cole Poirier 2020-08-08 21:37:49 BST
(In reply to Luke Kenneth Casson Leighton from comment #1)
> appreciate the help raising bugreports, in this case i planned and noted it
> 3 or so weeks ago.  however the subject libe is particularly obtuse.
> 
> *** This bug has been marked as a duplicate of bug 359 ***

Even better!
Comment 3 Cole Poirier 2020-08-08 21:39:06 BST

*** This bug has been marked as a duplicate of bug 359 ***