Bug 1016 - experiment reducing number of different instructions in int/fp move/convert
Summary: experiment reducing number of different instructions in int/fp move/convert
Alias: None
Product: Libre-SOC's first SoC
Classification: Unclassified
Component: Specification (show other bugs)
Version: unspecified
Hardware: PC Linux
: --- enhancement
Assignee: Luke Kenneth Casson Leighton
Depends on:
Blocks: 1015
  Show dependency treegraph
Reported: 2023-03-07 05:27 GMT by Jacob Lifshay
Modified: 2023-07-14 01:36 BST (History)
2 users (show)

See Also:
NLnet milestone: NLnet.2022-08-051.OPF
total budget (EUR) for completion of task and all subtasks: 1500
budget (EUR) for this task, excluding subtasks' budget: 1500
parent task for budget allocation: 1011
child tasks for budget allocation:
The table of payments (in EUR) for this task; TOML format:
[jacob] amount = 1000 submitted = 2023-06-28 paid = 2023-07-12 [lkcl] amount = 500 submitted = 2023-06-22


Note You need to log in before you can comment on or make changes to this bug.
Description Jacob Lifshay 2023-03-07 05:27:10 GMT
copy with modifications was at:
now merged back into:

I created a reduced instruction list as well as a bunch of notes.

* DONE: rewrite the rest of that file to match the new naming scheme.
* DONE: get everyone to look at it and agree on what we want to do
    * markos and jacob have reviewed it and want to keep old scheme
    * DONE: lkcl reviewed and we decided to use the new scheme but with the old scheme as instruction aliases, with a note that we considered the old scheme.
* DONE: if we decide we want the reduced instruction scheme, merge it back into int_fp_mv.mdwn (must wait till agreement is reached)
Comment 1 Jacob Lifshay 2023-03-09 09:13:10 GMT
markos looked at it and decided he likes the old unreduced scheme better:

i agree.
Comment 2 Luke Kenneth Casson Leighton 2023-03-14 14:58:23 GMT
(In reply to Jacob Lifshay from comment #1)
> markos looked at it and decided he likes the old unreduced scheme better:
> https://libre-soc.org/irclog/%23libre-soc.2023-03-09.log.html#t2023-03-09T09:
> 00:58

the answer was no, 6 months ago, and remains no.

Comment 3 Jacob Lifshay 2023-03-15 08:22:30 GMT
I rewrote int_fp_mv_reduced_insn_count and merged the changes into int_fp_mv, so  I'm marking this resolved. we can mostly copy sections into the RFC, I already did the hard work of writing the full pseudo-code and stuff (if anyone spots any bugs, do let me know!).


commit 16580f9f1a53f6f4a37701fcb397ef11286f9cb3 (HEAD -> master, origin/master, origin/HEAD)
Author: Jacob Lifshay <programmerjake@gmail.com>
Date:   Wed Mar 15 01:16:57 2023 -0700

    move int_fp_mv_reduced_insn_count.mdwn over int_fp_mv.mdwn

commit 648046411a9ae7399bdd9fb1b736ad7c157bcb5d
Author: Jacob Lifshay <programmerjake@gmail.com>
Date:   Wed Mar 15 01:16:15 2023 -0700

    copy changes over from int_fp_mv.mdwn

commit e5cb91f114797017c2981ae49f4270d362614aaa
Author: Jacob Lifshay <programmerjake@gmail.com>
Date:   Wed Mar 15 01:12:22 2023 -0700

    delete now-unnecessary section on experimental naming schemes

commit be35db55be1a155afdb9681a0ff28f5d20352fcb
Author: Jacob Lifshay <programmerjake@gmail.com>
Date:   Wed Mar 15 01:11:51 2023 -0700

    add note on considered alternative naming schemes

commit 5b3e3929d3102937ee4bd00d40c86ebe1b037519
Author: Jacob Lifshay <programmerjake@gmail.com>
Date:   Wed Mar 15 01:01:12 2023 -0700

    rewrite int_fp_mv_reduced_insn_count to account for reduced instructions changes